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Getting Started

This document shows an example of how to prepare a basic offline station in RoboDK for robot offline
programming. In this example, a UR robot is simulated and programmed for a robot painting application.

All the settings of a RoboDK project are saved as a RoboDK station (RDK file). A RoboDK station contains all
robots, tools, reference frames, objects and other parameters. The RoboDK station is stored in one file (RDK
extension). It is not required to keep a separate copy of the robot files, tools and objects as they are saved as
one RDK file.

The videos available in the examples section of RoboDK website provide an overview on how to use RoboDK
for different applications: hitps://www.robodk.com/examples.

New project
Follow these steps to create a new RoboDK project (RDK station):

1. Download and install RoboDK from the website: https://robodk.com/download

2. Double click the shortcut on the Desktop

3. If other stations are open:

select File> New Station (Ctrl+N) to start a new project

@ RoboDK - New station (1) - Professional (RoboDE) @ RoboDK - New station (3) - Professional (RoboDK)
File Edit Program View Tools Utilities Connect File Edit Program View Tools Utilities Conne

4 Mew station % Ctrl+M
&4 Open online library Ctrl+Shift+0

Open recent 4

| 4 ' 3D printing
| 4 ' Painting
4 ' Robot Milling 3 axes

M Save Station Ctrl+5
[ Save Station as...

"  Make a demeo station

Export Simulation Ctrl+E Milling
#  Close current Station Ctrl+F4 |_
O it Alt+F4

Multiple RoboDK projects can be open at the same time. Double clicking the Station icon - in the tree will
activate and display that project.
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Select arobot

New robots can be added from a local drive or from the online library:

1. Select FiIe%@ Open online library (Ctrl+Shift+O). A new nested window will appear showing the
online library

It is also possible to select the corresponding button in the toolbar. @
2. Use the filters to find your robot by brand, payload, ...

In this example, we will use a UR10 robot (10 kg payload robot and 1.3 m reach).
3. Select Download. The robot should automatically appear in the station in a few seconds.
4. The online library can be closed once the robot is loaded

Tip: Selecting reset filter in the online library will remove any filter that was used.

Tip: Alternatively, it is also possible to download the robot files (.robot extension) separately, from the website:
http://robodk.com/library and open them in RoboDK by drag & dropping the file to the main window or by
selecting File=>Open.

Note: Every time a new robot is loaded in RoboDK, a new reference frame is added representing the robot
base frame.

Note: Loading robots from the online library will store them in the local library. The default location of this folder
is: C:/RoboDK/Library/.

@ RoboDK - New station (1) - Professional (RoboDK)
File Edit Program View Tools Utilities Connect Help

@A yH OC HE @ Ml

L3

Web Library Opet

RoboDK library

© name v © brand v  fypev  axesv payload v reach = repeatability v
weight v LY

reset filter,

L

Comau Racer 7-1.4 KUKA LBR iiwa 7

Brand ‘ Brand
Type 6 DOF
Axes 6 Type 6 DOF
Payload7 kg Axes 6

Reach 1436 mm ayloa Payload 10 kg
Repeat. 0.020 mm eacl Reach 1300 mm

Weight 30 kg Repeat. 0.100 mm Repeat. 0.100 mm
Weight 24 kg Weight 29 kg

Download
Download Download

LY
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A Reference frame allows placing objects with respect to a robot or with respect to other objects in the 3D

Add a Reference Frame

space (including position and orientation).

Note: More information about reference frames in RoboDK in the reference frames section.

To add a new reference frame:

1.

2.

Select Program—)il; Add Reference Frame
Alternatively, select the equivalent button in the toolbar

Double click the reference frame (on the tree or on the 3D geometry on the main screen) to enter the
coordinates shown in the image (X,Y,Z position and Euler angles for the orientation). The mouse wheel
can be used on top of each case to quickly update the position of the reference frame on the main

screen.
The following colors are used by default:

X coordinate 2> Red

Y coordinate = Green

Z coordinate - Blue

1st Euler rotation > Cyan
2nd Euler rotation > Magenta
3rd Euler rotation = Yellow

O O O O O O

Tip: Select Tools>Options—>Display->Display XYZ axis letters to see the Coordinate system axes.

o gk w

If more than one reference frame is used, it is possible to drag and drop them inside the Station Tree to match
the dependency that exists in the real setup. For example, the reference Frame 2 may be placed with respect
to the robot base reference. In this case, if the UR10 Base reference is moved, the Frame 2 is also moved with
it. It is important to take this into account if other robots or reference frames are used. The next image shows

Select View—>Make reference frames bigger (+) to increase the size of the reference frames
Select View>Make reference frames smaller (-) to decrease the size of the reference frames
Select View->Show/Hide text on screen (/) to show or hide the text on the screen

Optionally, rename any reference frame or object in the tree by selecting F2

@M IC LY L@ Kbl @ »

v B Newstation (1) Faneoeas:Frane 2
v ...' UR10 Base Name: |FrameZ |
UR10 ( - » Visible
Ce '_ |Frame 2- _.T.) Reference position with respect to: | New station (1) 4
- [X,¥,Z]mm | Rot[X,¥',Z'']deg - Staubli (deg) ~ r =
-200.000 e.08e  100.808 0.888 9.808  120.800

Frame 2

LN

the difference in dependency.

Tip: Drag and drop reference frames (or any other items) in the tree holding the mouse right click to reorder

the items in the Station Tree (before other items, after or as nested items).
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v ' New Station (1)

¥ ___UR10 Base
UR10

Mowve before
Mowve nested

e

Muaowe after

Even if the dependency is different, it is still possible to enter or retrieve the coordinates of any reference frame
with respect to any other reference frame, as shown in the next image. Most robot controllers require the
coordinates of the reference frame with respect to the robot base frame.

"@H IC G @ Kk @ »

Frame Details: Frame 2

Name: |Frama 2 |

X Vishble
1 .
. - !
v Frame 2 i Reference position with respect to: ,.L UR10 Base Q A
. X,¥, 1 | Rot[x,¥",z'"]d st'LURmBase
Falip DX,¥*,7" " ]deg - 1 apply relative move

-8008.000 58e.080 18e.200 ’ :New station (1)
UR 10 (flange)

Frame Details: UR 10 Base g X

Name: [UR 10 Base
Visible

Reference position with respect to: | | Mew station (1)

Frame 2

m .

[X,¥,Z]mm | Rot[X,¥',z'']deg - Sthubli (deg) ~
e.e82 e.e88 2.002 2.e80 e.e88 0.0

@
@

Reference frames can also be moved in the main screen by holding the Alt key, or selecting the corresponding

L
button in the toolbar R\%. Then, drag the reference with the mouse on the screen. As the reference is being
moved, the corresponding coordinate values will be updated.

ﬂ@l‘l‘b@%@’ L N Rihe @ » u

e e 2 T1WC ses items keeping the relative position with the ck

Name: ‘Frame 2 |
Visble

Reference position with respect to: JS UR 10 Base hd

[X,¥,Z]mm | Rot[X,¥',Z'']deg - Stiubli (deg)
-368.000 58e.080 180.088 2.008

Frame 2

=
L

Import 3D objects

RoboDK supports most standard 3D formats such as STL, STEP (or STP) and IGES (or IGS) formats. Other
formats such as WRML, 3DS or OBJ are also supported (STEP and IGES are not supported on Mac and Linux

versions). To load a new 3D file:

1. Select File—)ﬂ Open

2. Select the object Object Inspection available in RoboDK'’s default library:
C:/RoboDK/Library/Object Inspection.

3. Alternatively, drag & drop files into RoboDK’s main window to import them automatically

4. Drag & drop the object to the reference frame Frame 2 (inside the station tree)

Getting Started with RoboDK 5




Tip: Drag & drop the object by holding the right click to reorder items inside the tree.

Important: It is important to place the object nested in the reference frame to teach the targets with respect to
the object. Then, if the reference frame is moved the targets are moved together with the object.

v ' Painting Test
¥ __._ URID Base

UR1O

w Maowve before

wu Paintigur
Move nested

w "'
' Chbject In Move after

Tip: For large STEP or IGES files it is possible to accelerate import speed by selecting:
Tools>Options>CAD->Fast import settings. More information available in the STEP/IGES section.

Tip: Although objects can be moved with respect to the reference frame they are attached to (by double
clicking the object and entering the coordinates), it is recommended to maintain them always with respect to
the given reference frame and move the reference frame instead. This allows matching the object reference
properly by just updating the reference frame from/to the robot controller.

w B New station (1) ‘ =N _ = w B New station (1) ‘ SN p—
w _ UR10 Base = ’ ! w _|_UR10Base h‘ )
LBty (7 UR10 &

. Frame 2 w 2 Frame2

L&

.
.4 Object Inspection

@)

UR10 Base

&)

evwilo Base

Frame 2

Create a TCP
New tools can be created in RoboDK from previously loaded 3D geometry:
1. Select FiIe—)“ Open (as described in the previous section)

2. Select the Paint gun.stl file to add it as an object (it will be added at the robot base frame)
3. Drag & drop the object to the robot item inside the station tree as shown in the next image

New tools can be loaded or saved as a .tool format.

; 3 : & x
\ ' New station (1) -~ Tool Details: Paint gun

3 ion (1)
w __ UR10Base .y 0 \ [y [Paint gun
UR10 7 1 . i visble [ Show TcP
r . aint guj o
w * Frame2 % Tool Center Point with respectto | % LR10 (fange) -
’ Object Inspection y [X,¥,Z]mm | Rot[X,Y',Z'']deg - Staubli (deg) ~ rl=

3 ' Object Inspection S
' Paint gun ) bj P qu Base
o
By default, RoboDK will define the TCP at the position [X,Y,Z]=[0,0,200] mm. This can be changed by entering
the coordinates manually and/or by moving the TCP holding the ALT+Shift key as shown in the next image:

More options...

'

1. Hold ALT+Shift or select the highlighted button from the toolbar
2. Select the light blue plane (XZ plane of the TCP) and drag the TCP approximately towards the surface
of the spray gun, as shown in the next image

Getting Started with RoboDK 6
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3. Select the Green rounded arrow (rotation around the Y axis) to make the Z axis point outwards

4. Once an estimate of the coordinates is obtained it is possible to touch up these values manually by
double clicking the Paint gun object. The mouse wheel can be used on top of each case to quickly
update the position on the main screen.

Note: These are estimate values according to the 3D drawings. If the definition of the TCP is calibrated on the
robot it is possible to import it by pasting the coordinates in that box.

H + 2w % %
x -
v ' MNew station (W] ﬁ-W" Tool Details: Paint gun mc'.-az items keeping the absolute position of the ch
] = bz N 4 Tool Name: [Paint gun |

¥ ___ UR10Base
v UR10 Visible Show TCP

.u Paint gun °\ ' Tool Center Point with respect to '; UR10 {flange)

m |

® oo o
w X Frame2 [%,Y,Z]mm | Rot[x,¥",z'']deg - Staubli (deg) -

- Object Inspection e.e08 B.8E8 ER

More options...

@

-l

At this point, the station can be saved:

1. Select File> 4 Save Station (Ctrl+S)
2. Save the file as Paint Test.rdk. The Window title and the Station name will be updated

Note: The following 2 subsections are optional and show hypothetical situations that require defining the TCP
in different ways. The modifications in these subsections will not be used in the following steps of this example.
To continue with this example, continue with the section showing how to create targets.

Set a relative TCP
It is possible to place a second TCP with respect to the first one, for example, to define a given standoff or to

place a cutter with respect to a spindle TCP.

These steps assume that a second TCP must be added with respect to the first one at 150 mm along the Z
axis:

Right click the robot

Select % Add Tool (TCP). A new item called Tool 2 will appear.

Double click this new TCP

Select Tool Center Point with respect to =>Paint gun

Enter the coordinate Z to 150 mm and set the other translations and rotations to 0.

arwd P
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Tool Details: Paint gun

Tool Name: |Paint qun
Visible Show TCP

Tool Center Point with respect to '; UR10 {flange)

4

o ;

%% Paint gqun A A

- , e

v Tool 2 o\‘ [X,¥,Z]mm | Rot[X,¥',Z"']deg - stiubli (deg) - =
¥ * Frame?2 78.000 8.880  479.8280 2.888 35.088 2.200

' Ob_ie::t Inspection More options. ..

}il’lt gun Tool Details: Toal 2 [
Tool Name: |TUU\ 2

Tool 2 visile 7] Show TCP
Tool Center Point with respect to \i\ Paint gun

+3

[X,Y,Z]mm | Rot[X,Y",I'']deg - Staubli (deg)
o.088 a.ee8 M a.a88 f8.888

4
m

@
@
@
@

More options...

This new TCP relative to the previously defined TCP will be removed in the next sections of this demonstration.

Move the Tool geometry
The geometry of the tool might not be aligned properly with respect to the robot flange (adaptor reference

frame) when it is loaded in RoboDK. The following steps assume that a mistake was made and the tool was
mounted 180 degrees around the Z axis, so the following correction should be applied:

1. Select More options in the Tool details window
2. Enter 180 in the yellow case (Z rotation) of the paint gun geometry, as shown in the following image.

The mouse wheel can be used on top of each case to quickly update the position on the main screen.

Tool Details: Paint gun

Tool Name: |Paint gun

Visible Show TCP

Tool Center Point with respectto & UR10 (flange) =<
[X,Y,Z]mm | Rot[X,Y',Z"']deg - Stdubli (deg) - =
78.888 @.ee8  478.000 8.e88 35,008 8.288
Hide option:
Apply Scale Change colors Edit events Apply move
Move geometry
[X,¥,Z]mm | Rot[X,¥ ,Z ]deg - Generic (default v I =
Paint gun 2.000 2.000 2.000 2.000 2.008

Tip: If the TCP was defined before this operation, the TCP won’t match the geometry anymore. To update the
position of TCP to the right location we could follow the steps described at the beginning of this section (by
holding the Alt key or entering the values manually). Alternatively, we could rotate the TCP around the robot
flange by selecting the Custom Pose representation method (as shown in the next image) and insert the Z

rotation pre-multiplying the TCP definition (at the beginning of the TCP line definition).

Tool Details: Paint gun

Tool Name: |Paint gun

Visible Show TCP

Tool Center Point with respect to ‘; UR.10 (flange) hd
Custom Pose ( ) transl(x,y,z}*rotz(rz)*... = =
Irutz(laa;*trlnsl .Baa,a.aaa,q?a.aaa:"rotx(a.aaa:*roty(ss.aaa:*rn‘

Hide options

Apply Scale Edit events Apply move

Move geometry
SEi aEE [

transl{e.eae,8.¥

2}*rotz{rz)*.

8@,8.008)frotz(188,. 088 Yroty (2. 808) *rotx(e.208)

Note: More information about how to provide transformations and poses available in the reference frames

section.
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Create Targets

Robot positions are recorded as Targets. Follow these steps to create two targets as a new home target and
approach target respectively:

1.
2.

3.

Double click the robot to show the robot panel

Select Paint gun as the Tool Frame. Once a tool or a reference frame becomes active it will show a
green dot.

Select Frame 2 as the Reference Frame

Hold the Alt key and move the robot by dragging it through the TCP or the robot flange to a safe
position, free of collisions with any objects. Alternatively, move the coordinates of the Tool Frame (TCP)
with respect to the reference Frame.

Use the Other configurations section to switch between different robot configurations and make sure
that none of the robot axes are close to the axis limits.

Tip: In general, it is better if the first target of a program has the joint axes as centered as possible (the joint
sliders are as centered as possible, as shown in the following image). This makes sure that the robot won’t
reach the axis limits as it follows linear moves along the program. This is possible by changing the robot
configuration.

6.

Select Program%@ Teach Target (Ctrl+T), or the corresponding button in the toolbar (as shown in
the image). The target will be placed as a dependency of the active reference frame and will
automatically remember the current robot position (cartesian and joints axes).

In this example, the robot joint coordinates used for the first target are: [-150, -75, -90, -60, 70, 110]

deg. These values can be copied from this text and “  pasted in the Joint axis jog of the robot panel
using the corresponding button.

Note: Selecting another reference frame will place the new target in that reference frame instead.

9.

L LIRS Jﬁ

v ' Painting Test
w ___UR10Base Name: [UR10 | | Parameters

@ KM@ b0 &EF -

w target for the selected robot UR10 panel

v UR10 Cartesian Jog

T Paint gun
a 7 Tool Frame | % Paintgun v | with respect to robot flange
w * Frame?2

. . . X,Y,Z1mm | Rot[X,Y',Z''ldeg - Staubli (deg) v =
Object Inspection 70.000 0.000  478.000 .00 35.000 .000

@ Target 1 (P Reference amemﬂ- respect to robot base

. TX.Y.Z1mm | ROEIX,Y". Staubli (deg) S
— -800.000 580.000 1e.000 ©.200 @.008 138.000

Tool Frame with respect to Reference Frame
[X,Y.,Zlmm | Rot[X.Y',Z''ldeg - Staubli (deg) nd M=
66.761  615.117 | 413.712  -178.685 13.316  177.924

Tool Frame ~ | workspace | Show Frames
X v z | @ Donotshow \DAIIM [ gase )
Transiation O O @ | O Show for wrist center | 4] Tool Frame I Rt e
Rotaton OO O | O show for robot flange | & Ref. Frame
O showforarenttool | I 02 3
: (O« Os DOs
1‘ )
\ /
i’

NS

Joint axis jog r Home
-150.00 [°-360.0 < > 360.0
-75.00 [°-360.0 < > 360.0
-90.00 [°-360.0 < > 360.0
-60.00 [°-360.0 < > 360.0
70.00 |°-360.0 < > 360.0
B 110.00 [°-360.0 < > 360.0

FREE i

Other configurations @ &, 8, 8., 85 8, | More options |
( *)-[-150.0€°, -75.00°, -90.80°, -60.00°, 70.0°, 110.00°] ¥

Rename the first target as Home by pressing F2. Alternatively, select Tools=>Rename item.

Move the robot closer to one edge of the part (by dragging the tool using the Alt key, entering
coordinates or jogging the axis manually)

In this example we used the following robot joint coordinates [0,0,200,180,0,180] deg.

Select Program%@ Teach Target (Ctrl+T) or the appropriate button in the toolbar to create a new
target

10. Rename the target to Approach as shown in step 7
Getting Started with RoboDK 9




11. Select the Home target and the Approach target alternatively to see the robot moving between the two
targets

12. Right click the target and select Teach Current Position (Alt+double click) if a different position needs
to be recorded for one of the targets

13. Right click the target and select N Target Options... (F3) to open the target options window shown
in the next image

W N el

UR10 panel 8 x

Name: [LR10 | | Parameters

Cartesian Jog

Tool Frame | ®\Paintgun ¥ with respect to robot flange:
FX,¥.Z1mm | ROE[X,v",Z' lder - Staubli (der) - T
70.000 e.000  a70.000 e.oee | 35.000 o.20

. Reference Frame Y| Frame2 + with respect to robot base
(ORI [X.¥.ZImm | ROL[X.¥",Z'*ldeg - Staubli (des) - gl
aeo.cee  See.co0|  100.000 e.c00 e.o00  1s0.c00

Tool Frame with respect to Reference Frame
TX.Y.Z1m | Rot[X.Y',2''lder - Staubli (deg) - =
39.343  3e2.497| 35,843 -179.289 7.853  17s.em1

A\

\ x Yz
| 0 Base Translation O O @
URl.] Base Roten QOO
Hame: [Approach a
ar
Visible Move to target Teach current position: / N
( )
Target type Approach L /\
@ Keep cartesian position -
O Keepjoint values B =
Joint axis jog Home
| -17m.27]e-360.0 < > 3600
Targe postion it respect : | Lrane

[%,Y,Z]mm | ROL[X,Y',Z'"]deg - Staubli (deg) - ris

008 o.000 | 200.000 -1%0.c68 e.000  -130.c28

Robot: T wRw - Change config,

8,
8,
8t
By
8,
8,
Robot joints:

[-210.13(2][ 54.038%]] 54.501/%]] -59.96 172 | 106.738% 545687 % | Other configurations @: & 8 8, 8 &) More options

()-[-178.27°, -76.31°, -34.27°, -56.56°, 98.82°, 90.78°] ~

If required, provide different values to define the targets.

Add an Approach Program

Follow these steps to create a program that moves from the Home target to the Approach target:

Dy
1. Select Program%b Add Program from the menu or the corresponding button in the toolbar (as
shown in the next image)
Rename the program to ApproachMove
Select the Home target

wn

4. Select Program%éz? Move Joint Instruction (or the corresponding button in the toolbar)

Two instructions will be added automatically to tell the robot what tool frame and reference frames we
are using

Note: If no target is selected, a new target will be created at the same location of the robot.
5. Select the Approach target

6. Select Program%éz? Move Joint Instruction again

Double click the ApproachMove program and it will execute the program simulation. The simulation bar and
an estimated cycle time will be displayed.

Getting Started with RoboDK
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O DEHE U@ Nl @ » u & F 28~

w B Painting Test
W¥ __._ UR10 Base
v UR10
X paint gun
w * Frame2
(.4 Object Inspection
@‘ Home
@‘ Approach

v
[~ 2. SetRef: Frame 2

1 -~ MoveJ (Home)

5; Set Tool: Paint gun

~ ~~ Move) (Approach)

I 124 5| ApproachMove time: 4.45 x

Note: More information about how to add robot programs and instructions is available in the robot program
section.

Create Targets on Surface

The Create Targets on Surface feature, is useful for applications such as painting or inspection:

1. Select Program%@/ Teach Target(s) on Surface (Ctrl+Shift+T)

2. Move the mouse cursor over the part to see a preview of what the robot looks like when it reaches the
part

3. Select a few points on the object (left click). Each mouse left click will define a new target keeping the Z
axis of the TCP normal to the surface (perpendicular to the surface).

4. If necessary, adjust the orientation around the Z axis by moving the wheel on the left panel or pressing
the left/right keys.

Hold Alt to move an existing target
Hold Alt+Shift to move an existing target while keeping it on the surface
Select Esc key or right click on the screen and select Done to exit the Create Targets on Surface mode

AOH DC HY U@ KMy @ »
. N M

Normal v ' Painting Test
Ww ___ UR10 Base
Select reference v UR10

No o

e

< " /'/—
54 ¥ paintgun <
) w * Frame2

(
\Wakt/ [ 4 obiemn‘
,‘ & Approach

Target 3

@

Target 4
Target 5
Target 6
Target 7
Target 8

@@ eeeeee

Target 9
@ Target 10

v . ApproachMove
2. SetRef.: Frame 2
= ; Set Tool: Paint gun

[~ —~ Move) (Home)
~ ~ Movel (Approach)

Once the targets have been created, generate a program following these steps:

Getting Started with RoboDK 11
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1. Select all the targets created on the surface and right click

Tip: Hold the Ctrl key to select multiple targets. Alternatively, select the Target 3, hold shift, then select Target
10 to select all targets between Target 3 and Target 10.

2. Select Rename group from the pop up menu

3. Enter Top Paint. All selected targets will be renamed and numbered.

4. Right click on the targets again and select Create Program. A new program will be generated. The first
movement will be a joint move and following movements will be linear.

Select F2 to rename the program to PaintTop

Double click the PaintTop program to see the simulation moving along the targets

If required, reorder the movements by dragging the move instructions inside the program

No o

Add a Retract Program

Similar to the previous operations:

1. With the robot placed at the last target, move the robot upwards by increasing the Z coordinate of the
TCP with respect to the reference frame in the robot panel (highlighted case in the next image)
Dy

Select Program—-> L=/ Add Program, or the appropriate button in the toolbar.

3. Select Program%fp Move Linear Instruction, or the appropriate button in the toolbar ", Rename it
to Retract by pressing F2 key.
Select the Home target

Select Program—)éﬁ? Move Joint Instruction. A new move instruction will be added, linked to the
Home target.

Simulate each program individually by double clicking it. The simulation can be accelerated by holding the
Spacebar key or selecting the Fast Simulation button #/ &,

Getting Started with RoboDK 12




UM IC HE L@ Nl @ o1 B H gL

w P rainting Test

Name: [(R10 | | Parameters

R Ppaint gun Cartesian Jog
w2 Frame2 Tool Frame | @\ Paintgun ¥ with respect to robot flange
[ J Object Inspection =
[X,Y,Z]mm | Rot[X,Y',z'']deg - Staubli (deg) - =
@& Home
70.000 e.e00 470.000 2e.eee 35.000 e.000
@& Approach
& Top Paint 1 Reference Frame Y| Frame2 v | with respect to robot base
@ Top Paint 2 [X,Y,Z]mm | ROt[X,v',z'']deg - Staubli (deg) = r[=
© 3 -300.000  500.000  100.000 o.000 e.000  130.000
s Tool Frame with respect to Reference Frame
@, [X,Y,Z]mm | Rot[X,Y',Z""']deg - Stdubli (deg) v =
& 25.987 366.613 169.825 154.411 0.000 -168.66@
Tool Frame ~ || Workspace | Show Frames
X v z | ® Donotshow Ol ANone [ gage (g)
Translation O O @ | O Show for wrist center Tool Frame
Robot Flange
Rotaton - OO O [ O show for robot flange Ref- FfaE'e -
e - L O show for current tool 1 2 3
. et Ref. Frame 2 4’ O: 0. 0O
M\ Set Tool: Paint gun (
~ MoveJ (Home) H \ /
|~ Moves (approach) Top Paint 8 -
w B rainttop - . e = -
- BB PaiRt 5 Joint axis jog Home
. SetRef.: Frame 2 &
. 8:|  -150.68|°360.0 < > 360.
& Set Tool: Paint gun € 15065 | SeX0.0 g0
3 - 8 -78.80 |°-360.0 < > 360.
~ Move) (Top Paint 1) \ Top Paint 7 78.80 | ©-360.0 360.0
I ) o 8| -107.42|°-360.0 < > 360.0
{~ " MoveL (Top Paint 2) \/ -
: 0 6 .60 |°-360.0 < > 360.
~~" Movel (Top Paint 3) “ ~62:60 [S0.0 go0.0
| 8. 3 -360.0 < > X
.~ Movel (Top Paint 4) 47.74|2-360.0 360.0
— .~ Movel (Top Paint 5) Be:|  114.25|9-360.0 € > 360.0
.~ Movel (Top Paint 6) Other configurations @. 8, 8, 8., 65 8) More options

~" Movel (Top Paint 7)
" Movel (Top Paint 8)
etract

Set Ref.: Frame 2

( *)-[-150.68°, -78.80°, -167.42°, -62.60°, 47.74°, 114.25°] <~

Set Tool: Paint gun
.~" Movel (Retract)
“ Move) (Home)

Main Program

A main robot program can execute the approach, paint and retract programs sequentially:

Select Program%@ Add Program

Select Program-> Program Call Instruction
Enter the name ApproachMove or select Select program to automatically select it
Select OK

Repeat the previous steps for PaintTop and Retract as shown in the next image

arn P

Double clicking the Main Program will run the complete simulation. Right click the Main Program and select
Loop to make it simulate in a loop.

Tip: Multiple lines can be typed when providing the program name as a program call. Each line will be
converted to a new program call instruction.
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w B painting Test

v B rainttop
Ref: Frame 2

.~ Movel (Top Paint 7)
-~ Movel (Top Paint 8)
4 B
Set Ref.: Frame 2

Set Tool: Paint gun
Movel (Retract)
MoveJ (Home)

%= Call Retract

If the reference frame Frame 2 is moved (for example, by holding Alt key and dragging the X/red axis of the
reference frame), the object and targets will follow. If the targets become not reachable, a small warning sign

will be displayed on the target icon @ as shown in the next image.

Tip: Select View>Show/hide robot workspaces (*) to display the robot workspace.

v ' Painting Test
W . UR10 Base
v UR10
L\ Paint gun
w * Frame?2
[ 4 Object Inspection
@' Home
@ g Approach
(] { Top Paint 1
@IL: Top Paint 2
I @A Top Paint 3
I @‘ Top Paint 4

Paint gun

(G] 4 Top Paint 5
[~ @h, Top Paint 6

Q Top Paint 7
Retract

(] i Top Paint 8
@. Retract
v . ApproachMove
[~ Set Ref: Frame 2

Set Tool: Paint gun

MoveJ (Home)
| Move) (Approach)
v . PaintTop

Export simulation

It is possible to export simulations as a 3D HTML or 3D PDF as well as distribute your station as a simplified
version of RoboDK (RoboDK Viewer).

Note: Exporting as 3D PDF is not available on Mac and Linux versions,
3D HTML and 3D PDF documents can be generated following these steps:

1. Right click the Main Program

2. Select 39’ Export Simulation...
3. Select Start. The program will start and the simulation will record until the program is completed.
4. Save the file. After the file is saved it will be automatically opened to preview it.

HTML and PDF simulations are saved as one single file. Compressing an HTML file will remarkably reduce its
size. PDF simulations must be opened with Acrobat Reader. Exporting PDF format is available for Windows
platforms only.

The following links are examples of 3D HTML simulations:
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o https://robodk.com/simulations/UR-Paint.html
o https://robodk.com/simulations/Welding-3-Fanuc-Robots.html
o https://robodk.com/simulations/Robot-Drawing.html

And the following links are examples of 3D PDF simulations:

o https://robodk.com/simulations/UR-Paint.pdf
o https://robodk.com/simulations/Welding-3-Fanuc-Robots.pdf
o https://robodk.com/simulations/Milling-with-External-Axes.pdf

O DCHE LIP K %—M@G

v ' Painting Test
P __ UR10Base
> . upp roachMove

Run

Run on robot
Loop

Show instructions
Display path
Locked

Check path

Generate robot prograrm...

Generate robot program F& Export format: G html ~

Send program to robot Ctrl+F6 Export type

Start on robot Fa () Custom simulation

Robot @ Existing program | | | MainProg
Select Post Processor

Export Simulation... Q

Add Instruction

Recording...

Delete

= Call ApproachMove

all PaintTop
:E Call Retract

Another way of exporting 3D simulations is by generating a self-extracting EXE file or a ZIP file with a reduced
version of RoboDK (available for Windows version only), as shown in the next image.

Note: This option is not available for Mac and Linux versions,
To generate this file:
1. Select FiIe—)@ Make a demo station

2. Select the preferred output (ZIP or EXE format)
3. Select Generate file

After a few seconds, it will generate the desired file (20 MB) which is a simplified version of RoboDK. The
station will automatically be loaded on start.
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https://robodk.com/simulations/Welding-3-Fanuc-Robots.html
https://robodk.com/simulations/Robot-Drawing.html
https://robodk.com/simulations/UR-Paint.pdf
https://robodk.com/simulations/Welding-3-Fanuc-Robots.pdf
https://robodk.com/simulations/Milling-with-External-Axes.pdf

@ RoboDK-Viewer - Painting Test - m] X
File Edit View Tools Help X

DC HE LI@ KL PQ ke »

v Painting Test
P _ UR10Base
v . ApproachMove
& Set Ref.: Frame 2
M\ Set Tool: Paint gun
~ Move) (Home)
~~ MoveJ (Approach)
» B PaintTop
v . Retract
‘ : . Set Ref: Frame 2
[~@ Set Tool: Paint gun

}” .~ Movel (Retract)
— ~~ MoveJ (Home)
v "ﬂ MainProg
- %= Call ApproachMove
#= Call PaintTop
%= Call Retract

J(IM|[ B[ H| Y I 502 |+ |PaintTop time: 31.1s ®

Generate Robot Program
It is possible to export any program individually or the main program including the subprograms:

1. Right click a program (MainProg for example)
2. Select Generate robot program (F6)

Alternatively, select Generate robot program... to specify the location to save the file
3. The SCRIPT program for UR robot will be displayed in a text editor

This file is the result of generating the program offline. The file can be sent to the robot controller to run the
same movements that were simulated in RoboDK.

Tip: If we are properly connected to the robot we can also select one of the following options in the same
menu:

o Select Send program to robot (Ctrl+F6) to send the program through FTP (Offline Programming)

o Select Start on robot (F8): to send the program to the robot and execute it (Offline Programming)

o Check the option Run on robot to run the program step by step each time we run the program (Online
Programming). This allows executing the program on the robot as it is simulated at the same time.
Robot drivers are required for Online Programming.
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=] MainProg script E3

def MainProg():
§ Default parameters:
3 global speed ms = 0.300
int gun 4 glebal speed_rads = 0.750
. 5 glebal zeeel mss = 3.000
ove) (Home) & global zccel_radss = 1.Z00
7 glebal blend radius_m = 0.001

Viove) (Approach)
¢ Add any suprograms here
# Subprogram ApproachMove
def ApproachMovel):
# set_reference(p[-0.300000, 0.500000, 0.100000,
set_tcplpl[0.070000, -0.000000, 0.470000, -0.00000C
s moved {[-2.617984, -1_308887, -1_570796, -1 047138,
s move]([-3.667538, -1.641284, -1.480071, -1.046528,
Display path & end
Locked

Run
Run on robot

Loop

Show instructions

# Subprogram PaintTop

Check path

413:! a. 13¢1an
S424, 0.130832

Generate robot program... 2 movelip[-1.1& 7
23 movelip[-0.823833, O

Generate robot program ﬁ F& movelip[-0.8 0.237 033 0.1
Send program to robot Ctrl+F& 25 movel (p[-1.1 0.240160, 0.1
28 movel (p[-1.1 0.12339¢, 0.1
movel{p[-0.825987, 0.133387, 0.139825,
end

Start on robot

Rebot
§ Subprogram Retract
o Set Ref: Frame B Select Post Processor def Retract():
- movel (p[-0.825987, 0_133387, 0_ 269825, -2 683331,
a0 movej([-2.617984, -1.308887, -1.57079&, -1.047188,
end

Set Tool: Paint d Export Simulation...
" Movel (Retract] AT
§ Main program:
§ Program generated by RoboDK 3.2.0 for URLO0 on 22/C
§ Using nominal kinematics.
ApproachMove (]
BaintTep!)
2etracsi)
& Znd of main program
end

~ Movel (Home)
Delete
v

Call ApproachMove
Call PaintTop
= Call Retract

MainProg()

Tip: Offline Programming with RoboDK involves using a post processor that defines the syntax used to
generate each program. RoboDK provides many post processors to support different brands. More than one
post processors might be available for a specific robot controller.

It is possible to change the post processor for UR robots and customize the way a program is generated:

1. Right click a program or a robot

2. Select . Select Post Processor
3. Select Universal Robots

Note: Post Processors that have a black icon can be modified by selecting Program->Add/Edit Post
Processor.

Generate the program again. In this example, the default post processor uses joint values to define each linear
move and the second post processor uses cartesian coordinates to define each linear move.

Using Macros

The RoboDK API allows customizing the simulation as much as desired. By default, RoboDK installs Python
and a set of sample macros that allows a higher level of customization. This includes simulating a paint gun,
programming robots through Python, simulating 2D cameras, converting SVG files to robot programs,
automatically setting a TCP given a standoff, simulating discrete events and much more. Other programming
languages can also be used, such as C# or Matlab. For more information visit:
https://robodk.com/doc/PythonAPl/intro.html

In this example, we will add an existing sample macro that will simulate the behavior of the paint gun. We will
also recolor the spray volume with a transparent color (by selecting Tools=>Change color tool - Shift+T) or
load the existing model with appropriate colors (available from the local library as paint_gun.tool or the online
library, note that the Set Tool instruction might need to be updated to link to the new tool).

Select File—)“ Open to open a new Python macro (py file)
Navigate to C:/RoboDK/Library/Macros/ to see some sample macros
Select SprayOn

» wbhe

Select Open. A new Python object @ will be added. This macro allows simulating particle deposition
modeling the spray volume.
5. Double click the SprayOn macro to test it
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No

Select On to activate it

Hold Alt key, drag the robot flange and move the robot along the surface with the Paint gun.

You should see the trace of the paint gun. The color and transparency should change depending on
how close or far the TCP is from the surface.

Select Esc once to clear the simulated paint.

Double click the same SprayOn program and select Off to turn the particle simulation Off.

QM IDCHY :: N DNle @ » u @ fE

’ Painting Test v

¥ ___ UR10 Base
v UR10
T Paint gun
P * Frame2
v . ApproachMove
& Set Ref.: Frame 2

A\ Set Tool: Paint gun
«~ MoveJ (Home)
~~ MoveJ (Approach)
14 - PaintTop
v - Retract
o Set Ref: Frame 2
S\ Set Tool: Paint gun
+” Movel (Retract)

~~ MoveJ (Home)

AainProg

§- O X
L=Es Call Retract Turn gun ON or OFF
e

N -

To better understand what happens behind the scenes, it is possible to view or edit the Python code the
following way:

1.
2.

Right click @ SprayOn
Select Edit Python Script

A new window (text editor) will appear showing the code that models the spray behavior and how Python is
integrated with RoboDK.

To take the spray simulation into account in the main program we can follow these steps:

1.
2.

Select the instruction Call ApproachMove

Select Program%g Program call Instruction, a new instruction will be added after the first program
call and a new window will pop up

Enter SprayOn(1)

Select OK

Repeat the same operation after the PaintTop program setting SprayOn(0), as shown in the following
image.

If necessary, reorder the instructions by drag & dropping them within the program.

Run the MainProg program. After two iterations, the result should look like as shown in the image
(simulating at normal speed).
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v ' Painting Test
W ___ UR10 Base
v UR10
L\ Paint gun
P * Frame2
v . ApproachMove
o SetRef: Frame 2
5* \ Set Tool: Paint gun
~ Movel (Home)
~~ MoveJ (Approach)
> . PaintTop
v . Retract
. Set Ref.: Frame 2
Set Tool: Paint gun
~" Movel (Retract)
— ~~ Movel (Home)
v . MainProg
| [~ == call ApproachMove

o

Call PaintTop
Call SprayOn(0)
‘ == Call Retract
- fgh SprayOn

It is also possible to add new macros:

Getting Started with RoboDK

2l m A
b |

@ Add Program call or Custom code X

Program Cal

Select program

1. Select Program%e) Add Python Program
2. Right click the new program and select Edit Python Script

PR @ >0 ®

Next: RoboDK supports setting the robot speed within the program, setting digital outputs, waiting for digital
inputs, displaying messages, etc. These instructions are available under the Program menu.
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